WixでUpgradeVersionを指定する方法

@iwasaki 144views 更新:2015年5月12日

WixでUpgradeVersionを指定することでアップグレード対象を制限することが可能です。

OnlyDetectオプション:インストール済のものを残す場合:yes、削除してごそっと入れなおす場合:no

        <Upgrade Id="XXXXXXXXXXXXXXXXXXXXXXX">
            <UpgradeVersion OnlyDetect="yes" Property="OLDFOUND" Minimum="1.0.0.0" IncludeMinimum="yes" Maximum="1.0.1.0" IncludeMaximum="no" />
            <UpgradeVersion OnlyDetect="yes" Property="NEWERFOUND" Minimum="1.0.1.0" IncludeMinimum="yes" />
        </Upgrade>

ログイン / 新規登録してコメントする

このソースコードをストックして後で利用したり、作業に利用したソースコードをまとめることができます。

こちらもお役に立つかもしれません