Circle CI で cupertino を利用するとエラーが発生する

nbeppu 89views 更新:2015年5月21日

Circle CI 環境で cupertino の最新版を実行するとエラーが以下のエラーが発生します。

ios profiles:download:all -u $APPLE_DEVELOPER_ID -p $APPLE_DEVELOPER_PASSWORD --type distribution

/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/specification.rb:1206:in `block in activate_dependencies': can't satisfy 'highline (>= 1.7.1)', already activated 'highline-1.6.21' (Gem::LoadError)
    from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/specification.rb:1198:in `each'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/specification.rb:1198:in `activate_dependencies'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/specification.rb:1180:in `activate'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:48:in `gem'
    from /usr/bin/ios:22:in `<main>'

こちら https://github.com/nomad/cupertino/issues/208 でも報告されているようですが、highline の依存関係の問題のようです。 取り急ぎ、以下のように circle.yml を調整して対応しました。highline (1.7.1) の依存関係が指定される一つ前のバージョンを利用しています。

dependencies:
  override:
    - sudo gem install cupertino -v 1.3.2

ログイン / 新規登録してコメントする

このソースコードをストックして後で利用したり、作業に利用したソースコードをまとめることができます。

こちらもお役に立つかもしれません