Macでgemコマンド実行時にエラー

@iwasaki 852views 更新:2015年6月17日

以下のコマンドをMacで実行した時にエラーが出ました

sudo gem update --system
Updating rubygems-update
ERROR:  While executing gem ... (Errno::ENOENT)
    No such file or directory - getcwd

gemの環境変数を表示してみます。

$  gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 2.0.14
  - RUBY VERSION: 2.0.0 (2014-05-08 patchlevel 481) [universal.x86_64-darwin14]
  - INSTALLATION DIRECTORY: /Library/Ruby/Gems/2.0.0
  - RUBY EXECUTABLE: /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby
  - EXECUTABLE DIRECTORY: /usr/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - universal-darwin-14
  - GEM PATHS:
     - /Library/Ruby/Gems/2.0.0
     - /Users/hoge/.gem/ruby/2.0.0
     - /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/gems/2.0.0
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - https://rubygems.org/

どうやらエラーの原因としてはgithubからcloneしたリポジトリのフォルダでこのコマンドを実行したせいのようでした。

ディレクトリを移動してコマンドを実行しなおしてみました。

cd ~/
sudo gem update --system

ログイン / 新規登録してコメントする

このソースコードをストックして後で利用したり、作業に利用したソースコードをまとめることができます。

こちらもお役に立つかもしれません