【Xcode】CocoaPodsをアップデートする

Yukimi Sato 186views 更新:2015年6月23日

環境作り直しは過去のハックが役に立ちました!
【Xcode】環境作り直し時のメモ

久しぶりに環境を作っていたらビルドでコケるので、エラーを確認したら「pod installしてくれ」と出ていたので、
やってみたところ、バージョンが古いとそこでエラーが出ます。

こんなエラーです。

[!] The version of CocoaPods used to generate the lockfile (0.36.4) is higher than the version of the current executable (0.35.0). Incompatibility issues may arise.

しばらく放っておくと、

CocoaPods 0.37.2 is available.
To update use: `gem install cocoapods`

と、新しいバージョンを自動で引っ張って来てくれます。
そのまま進まない場合は gem install cocoapods を入力して新バージョンのインストールを実行してください。 基本は放置しておくと勝手にインストールが始まります。

ログイン / 新規登録してコメントする

このソースコードをストックして後で利用したり、作業に利用したソースコードをまとめることができます。

こちらもお役に立つかもしれません