atomicorpのOpenVAS 8でniktoプラグインが動作しない

Tetsuro Aoki 96views 更新:2015年8月11日

atomicorpからyumインストールしたOpenVAS 8でniktoプラグインが動作していなかったのでなんとかしてみました。

エラーメッセージは以下の通り

Here is the Nikto report:
Can't locate /usr/share/nikto/plugins/LW2.pm in @INC (@INC contains: /usr/local/lib64/perl↵
5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/li↵
b64/perl5 /usr/share/perl5 .) at /usr/bin/nikto line 57.

LW2.pmがないと怒られているようです。
このLW2.pmとはperlのlibwhisker2というモジュールのことを指すようです。

このモジュールのパッケージはatomicorpのリポジトリに用意されているのですがインストールしてもうまく動作してくれません。
仕方がないので少々無理矢理ですがniktoのgithubからLW2.pmだけもらってくることにします。

git clone https://github.com/sullo/nikto.git
cp nikto/program/plugins/LW2.pm /usr/share/nikto/plugins/

これでスキャンを実行したところ正常に動作しました。

ログイン / 新規登録してコメントする

このソースコードをストックして後で利用したり、作業に利用したソースコードをまとめることができます。

こちらもお役に立つかもしれません