古いAmazonLinuxでpip2.7を入れたりする

alkoshikawa 20views 更新:2016年3月23日

昔のAmazonLinuxだとPython2.6系がメインなんですが、2.6系でプログラムを実行するとエラーが出ることがよくあります。

2.7系を使うには以下のような形でモジュールをインストールします。

yum install python27-devel
yum install libffi-devel

wget https://bootstrap.pypa.io/get-pip.py
python27 get-pip.py 
pip2.7 install pyopenssl

実行には

python27 {python_program}

とかです。

ログイン / 新規登録してコメントする

このソースコードをストックして後で利用したり、作業に利用したソースコードをまとめることができます。

こちらもお役に立つかもしれません