[Apache] TLSのバージョンによって処理を変更する

Yuya Sato 6views 更新:2017年6月7日

TLSのバージョンによって、他のページやサイトに遷移させたりする場合は、.htaccessに以下のような設定を記述する。

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{SSL:SSL_PROTOCOL} !^TLSv1\.2$
RewriteRule ^(.*) http://google.co.jp [R=301,L]
</IfModule>

上の設定では、TLSv1.2以外のバージョンでアクセスされた場合googleにリダイレクトするようになる。

ログイン / 新規登録してコメントする

このソースコードをストックして後で利用したり、作業に利用したソースコードをまとめることができます。

こちらもお役に立つかもしれません