React NativeでMigration is required due to the following errorsが出た時の対処法

@iwasaki 10views 更新:2017年6月14日
react-native run-ios

react-native run-android

した際に以下のようなエラーが出ました。

Migration is required due to the following errors:
- Property 'XXXX' has been added.

このようなエラーが出た際にはアプリをアンインストールした上で再度インストールし直すといいようです。

iPhoneのシミュレータの場合

「Hardoware」→「Home」→アプリアイコン長押し→「x」ボタンクリック

Androidのシミュレータの場合

「設定」→「アプリ」→該当アプリを表示→「アンインストール」

ログイン / 新規登録してコメントする

このソースコードをストックして後で利用したり、作業に利用したソースコードをまとめることができます。

こちらもお役に立つかもしれません