古いバージョンのPostgreSQLのコンパイルでエラーが出たらGCCも古いバージョンにする

高瀬 裕介 1,663views 更新:2014年6月12日

コンパイル時にこんなんがでたら

initializing pg_authid ... FATAL:  wrong number of index expressions
STATEMENT:  CREATE TRIGGER pg_sync_pg_database   AFTER INSERT OR UPDATE OR DELETE ON pg_database   FOR EACH STATEMENT EXECUTE PROCEDURE flatfile_update_trigger();

GCCを旧バージョンに差し戻す

yum install gcc47
alternatives --config gcc
#gcc47を選択

ログイン / 新規登録してコメントする

このソースコードをストックして後で利用したり、作業に利用したソースコードをまとめることができます。

こちらもお役に立つかもしれません