Apache2.2の環境にphp4、php5を入れてhttpdが起動しなくなったら

高瀬 裕介 208views 更新:2014年7月28日

/etc/httpd/conf/httpd.conf に 下記の行が出来上がるのでこちらをコメントアウト

LoadModule php4_module        /usr/lib64/httpd/modules/libphp4.so

/etc/httpd/conf.d/php.conf を編集して下記のようにphp5のLoadModuleの下でphp4のモジュールをロードするようにする

  <IfModule prefork.c>
  LoadModule php5_module modules/libphp5.so
  LoadModule php4_module modules/libphp4.so
  </IfModule>

ログイン / 新規登録してコメントする

このソースコードをストックして後で利用したり、作業に利用したソースコードをまとめることができます。

こちらもお役に立つかもしれません