Aipoをビルドする時にThreadPoolingDataSource.javaでエラーが出る場合の対処法

otaguro 314views 更新:2014年8月28日

Aipoをビルドする際にThreadPoolingDataSource.javaで

[40,7] エラー: ThreadPoolingDataSourceはabstractでなく、CommonDataSource内のabstractメソッドgetParentLogger()をオーバーライドしません

というエラーが出る場合には、

java -version
javac -version

でバージョンが1.6.0_45になっていることを確認する。
もし、バージョンが違うようであれば、
環境変数JAVA_HOMEとコントロールパネルの「プログラムのアンインストールまたは変更」を調整する。

ログイン / 新規登録してコメントする

このソースコードをストックして後で利用したり、作業に利用したソースコードをまとめることができます。

こちらもお役に立つかもしれません