gem install aws-sdkでエラーになる時の対処法

@iwasaki 617views 更新:2014年10月7日

Ruby版のaws-sdkをインストールしようとした時に以下のエラーが出ることがあります。

# gem install aws-sdk
Fetching: mini_portile-0.6.0.gem (100%)
Successfully installed mini_portile-0.6.0
Fetching: nokogiri-1.6.3.1.gem (100%)
Building native extensions.  This could take a while...
ERROR:  Error installing aws-sdk:
        ERROR: Failed to build gem native extension.

    /usr/bin/ruby2.0 extconf.rb
mkmf.rb can't find header files for ruby at /usr/share/ruby/include/ruby.h


Gem files will remain installed in /usr/local/share/ruby/gems/2.0/gems/nokogiri-1.6.3.1 for inspection.
Results logged to /usr/local/share/ruby/gems/2.0/gems/nokogiri-1.6.3.1/ext/nokogiri/gem_make.out

ログが出力されているようなので、ログファイルを見てみます。

# cat /usr/local/share/ruby/gems/2.0/gems/nokogiri-1.6.3.1/ext/nokogiri/gem_make.out
/usr/bin/ruby2.0 extconf.rb
mkmf.rb can't find header files for ruby at /usr/share/ruby/include/ruby.h

新しい情報は特に載っておらず。。。

ググってみたところ、ruby-develをインストールすれば直ります。

# yum install ruby-devel
# gem install aws-sdk

ログイン / 新規登録してコメントする

このソースコードをストックして後で利用したり、作業に利用したソースコードをまとめることができます。

こちらもお役に立つかもしれません