うちの鯖、POODLE対応は必要?SSLv3が有効か確認するコマンド

高瀬 裕介 5,416views 更新:2014年10月16日

openssl コマンドを実行して、SSL handshakeが成立した場合はSSLv3が有効ですのでPOODLEの影響を受ける可能性があります。

# openssl s_client -connect localhost:443 -ssl3
CONNECTED(00000003)
...
---
SSL handshake has read 1629 bytes and written 302 bytes
---
New, TLSv1/SSLv3, Cipher is DHE-RSA-AES256-SHA

ログイン / 新規登録してコメントする

このソースコードをストックして後で利用したり、作業に利用したソースコードをまとめることができます。

こちらもお役に立つかもしれません