neovim

python3必須ではありますが、deinなどと組み合わせると非常に協力なエディタになるneovimですが、amazonlinux2では、yumでのインストールがうまく行かなかったので,makeをつかって入れてしまいました。

sudo yum groups install -y Development\ tools
sudo yum install -y cmake
sudo yum install -y python34-{devel,pip}
sudo pip-3.4 install neovim --upgrade
(
cd "$(mktemp -d)"
git clone https://github.com/neovim/neovim.git
cd neovim
make CMAKE_BUILD_TYPE=Release
sudo make install
)